Pockethernet Hardware > Issues

No DHCP on accessport w/ VLAN tag

(1/2) > >>

I don't know if I should bump this old thread or that I just should open a new one, but the problem I'm facing is quite similar to what's being described here:
Today I received a new Pockethernet, when I enter a valid VLAN ID as outgoing VLAN Tag, I get DHCP information.
When I don't enter a valid VLAN ID, I'm not getting DHCP information

The port configuration is as follows:
Switch: HP Procurve 2910 J9148A with latest firmware
Switch: HP Procurve 2920 J9728A with latest firmware
(both switches show the same problem)
VLAN 15 untagged
VLAN 25 tagged (voip)

Outgoing VLAN Tag selected with VLAN ID 25:
- switch shows MAC-address in VLAN 25
- DHCP information received
- while running traffic sampling, I see traffic from both untagged VLAN 15 and tagged VLAN 25

Outgoing VLAN Tag unselected:
- switch shows MAC-address in VLAN 15
- no DHCP information
- while running traffic sampling, I see traffic from both untagged VLAN 15 and tagged VLAN 25.

Although I didn't expect anything, I just ran some tests:
Outgoing VLAN Tag selected with VLAN ID 15, no DHCP information
Outgoing VLAN Tag selected with VLAN ID 0, no DHCP information
Outgoing VLAN Tag selected with VLAN ID -1, no DHCP information

I also tried different locations, connected to different switches, different VLAN's. Other devices like computers, laptops or VOIP telephones get the right DHCP information. Even when I'm putting the PE behind a VOIP-phone, the PE does not get any DHCP information.

The Pockethernet is running HW version 06, firmware 29
Android app version 2.8a
iPhone app version 2.61

I hope anybody can help me or give me any directions how to debug this.

Bump... Is there anybody out there who might be able to help me fix this or at least help me debug this issue so the developers might fix it?

Try setting the DHCP timeout, under settings, to 60sec. This worked for me.
Update for clarification: I was having issues getting an IP via DHCP from certain switches. I was not attempting to use the Outgoing VLAN Tag feature.


Unfortunately it doesn't help. But it made me investigate further and this is what I noticed:
We're running Windows 2012R2 DHCP in Load Balanced failover. The logging reports:
36,08/31/18,13:14:17,Packet dropped because of Client ID hash mismatch or standby server.,[subnet],,[mac-address],,0,6,,,,,,,,,0

This pointed me to several articles spread all over the mighty interwebs, most of them somehow pointing at the failover configuration. It seems to happen especially with non-Windows devices. Although I'm still far away from fixing it permanently, I am able to fix it temporarily by switching from 'Load Balanced' to 'Hot Standby'

This article is pointing at a specific value in DHCP Discover packets which might be missing. (I can't confirm that yet)

I just posted in an older thread about this issue. Take a look: https://forum.pockethernet.com/index.php?topic=154.msg1524#msg1524

In short, do not check "Outgoing VLAN Tag" when running tests. It should only be used, along with the correct VLAN #, when testing for VLAN connectivity.


[0] Message Index

[#] Next page

Go to full version