Author Topic: Intermittent Link test and DHCP test failing  (Read 1031 times)

ceejm1

  • Newbie
  • *
  • Posts: 3
Intermittent Link test and DHCP test failing
« on: March 27, 2018, 03:26:44 PM »
Hello,

I seem to be having intermittent issues with Link/DHCP tests failing.

Testing on a draytek vigor router and also a netgear GS116 tests operate as expected.

However, when connected to a ubiquiti toughswitch 5 port neither test completes.  A PC plugged into the same port receives DHCP and performs as expected.

When watching the unifi web interface the port becomes 'unconnected' before the test seems to finish...

If I cascade a simple switch off the toughswitch (a netgear FS105) then this holds the port 'up' on the toughswitch but the same behaviour shows on the link LED on the netgear - ie the link light goes out before the PE test appears to have completed.  The only difference with this setup is if I select only a link test then it works correctly but if i select both a link and a dhcp test both fail.

Its as though the PE is disconnecting before the tests finish yet it seems to work fine on another switches...

Its irritating not to to be able to trust a piece of test equipment - I spent a lot of time wondering why I wasn't getting DHCP on a particular VLAN on the toughswitch until I finally connected a PC and it was actually working as it should have...

Any thoughts on the matter??

Hardware version 6
Firmware version 29
App version 2.6i

James

ceejm1

  • Newbie
  • *
  • Posts: 3
Re: Intermittent Link test and DHCP test failing
« Reply #1 on: April 03, 2018, 04:37:21 PM »
Bump - Any thoughts on this issue?

James

snowmanjax

  • Newbie
  • *
  • Posts: 27
Re: Intermittent Link test and DHCP test failing
« Reply #2 on: April 03, 2018, 05:48:42 PM »
Does your ubiquiti switch have passive POE? I've seen unreliable tests on ubiquiti switches until I turned the passive POE off. As passive POE isn't a standard exactly, a decent amount of testers have issues with it. Fluke's Microscanner has issues with it as well, so I can confirm it's not just the PE device.

Hope that helps you, as it solved my issue.


snowman

ceejm1

  • Newbie
  • *
  • Posts: 3
Re: Intermittent Link test and DHCP test failing
« Reply #3 on: April 03, 2018, 06:03:52 PM »
It does have that option but it is turned off on the port under test.

Thanks
James

islanderfj

  • Newbie
  • *
  • Posts: 2
Re: Intermittent Link test and DHCP test failing
« Reply #4 on: April 12, 2018, 11:43:51 PM »
Same issue here.

Just got my PE, Hardware version 6, Firmware version 29, App Version 2.8a (Android)
Worked at home with my Asus AC3200 router, but at the office running Cisco C6880 switches.  Changed DHCP timeout to 60 seconds.  DHCP fails.  Plugged in a PC and got an IP with no issues. 

Kinda critical - you think?

BWheetley

  • Newbie
  • *
  • Posts: 2
Re: Intermittent Link test and DHCP test failing
« Reply #5 on: April 13, 2018, 05:14:31 PM »
I'm also having unreliable test results with the DHCP / Ping tests.  I use static IPs on our connections so it's not related to whether or not the device receives an IP address from a DHCP server.  So in the Pockethernet app I set the static IP, netmask, gateway, and DNS.  In the Ping section I set it to ping the gateway address, google's DNS server (8.8.8.8), and a FQDN such as www.google.com.  Sometimes all three hosts will time out.  99% of the time the gateway IP will time out and the other two will respond.  We test on Cisco 6509 with WS-X6748-GE-TX line cards as well as Cisco 4948 switches.  Ports on the Cisco side are usually set as:

 ip address X.X.X.X N.N.N.N
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 speed auto 10 100
 no cdp enable
 spanning-tree portfast edge
 
-----

App:  IOS 2.6i
H/W Ver: 6
F/W:  29

islanderfj

  • Newbie
  • *
  • Posts: 2
Re: Intermittent Link test and DHCP test failing
« Reply #6 on: April 13, 2018, 11:27:08 PM »
I noticed something - if I turn off the Outgoing VLAN tag test, I am able to get DHCP consistently.

JP

  • Newbie
  • *
  • Posts: 33
Re: Intermittent Link test and DHCP test failing
« Reply #7 on: May 09, 2018, 05:39:56 PM »
If you request a DHCP lease too soon (as in too soon from when you first requested it) the DHCP server does not "respond" with a new/same lease.  This is some kind of protection (or perhaps an error) in many DHCP servers I've encountered.

Normal DHCP traffic is expecting: 1st/initial request, another request at half the least time (to renew with the same address), and again at the end of the lease time (to renew with the same address if the device is still there)

This is not a Pockethernet problem in my mind.  I have the same problem with Arduino boards and RasPi, when testing and rebooting continually sometimes the devices will not pickup a DHCP lease, but you wait longer and then it does.  Same behavior is seen regardless of using a DHCP reservation or not.

See DHCPoffer vs. DHCPrequest vs. DHCPinformation https://en.wikipedia.org/wiki/Dynamic_Host_Configuration_Protocol

jboxtel

  • Full Member
  • ***
  • Posts: 157
Re: Intermittent Link test and DHCP test failing
« Reply #8 on: May 15, 2018, 02:29:59 PM »
Thanks for all the input. We're looking into this issue.

TheFrin

  • Newbie
  • *
  • Posts: 1
Re: Intermittent Link test and DHCP test failing
« Reply #9 on: June 21, 2018, 10:37:41 AM »
I noticed something - if I turn off the Outgoing VLAN tag test, I am able to get DHCP consistently.

I had the same problem, this cured it. Thanks!

thetechfirm

  • Newbie
  • *
  • Posts: 1
  • Fixing things a bit at a time
    • The Technology Firm
Re: Intermittent Link test and DHCP test failing
« Reply #10 on: July 11, 2018, 06:04:30 PM »
I noticed something - if I turn off the Outgoing VLAN tag test, I am able to get DHCP consistently.

awesome observation.  fixed it for me as well.  i couldn't get DHCP to work on a Cisco 3750 switch/

thank you
Tony Fortunato
Sr Network Performance Specialist
The Technology Firm
www.thetechfirm.com

Getting things to work better - bit by bit-
Linkedin Profile http://ca.linkedin.com/in/fortunat
Google Plus: http://plus.google.com/+Thetechfirmplus
Youtube Channel: http://www.you

Tom

  • Newbie
  • *
  • Posts: 8
Re: Intermittent Link test and DHCP test failing
« Reply #11 on: July 12, 2018, 05:27:32 AM »
..
« Last Edit: August 10, 2018, 10:58:11 AM by Tom »