Author Topic: Arch Linux and NixOS don't show any tty device in dmesg  (Read 590 times)

Sigi

  • Newbie
  • *
  • Posts: 3
Arch Linux and NixOS don't show any tty device in dmesg
« on: October 10, 2016, 11:21:01 AM »
Hi,

i have Arch Linux and NixOS running but both are not showing any information about a tty device when i plugin the pockethernet.

I'm trying to do a firmware update.

Tx,

Sigi

jboxtel

  • Administrator
  • Full Member
  • *****
  • Posts: 142
Re: Arch Linux and NixOS don't show any tty device in dmesg
« Reply #1 on: October 10, 2016, 12:06:18 PM »
Hi Sigi.

There should be no linux specific differences so it should work on any version.

- What's your current SW version?
- Could you try to plug it into USB, then press and hold the power button for 10 secs

Sigi

  • Newbie
  • *
  • Posts: 3
Re: Arch Linux and NixOS don't show any tty device in dmesg
« Reply #2 on: October 10, 2016, 02:19:42 PM »
Hi,

not sure what SW you mean:

My Pockethernet is old. Firmware version < 20 (because thats the only thing i can see in the app)
Arch Linux has the 4.7.5 Kernel, NixOS has a lower kernel version.

The output from dmesg is only:

[447978.822505] usb 1-3: USB disconnect, device number 11
[448104.823589] usb 1-3: new full-speed USB device number 12 using xhci_hcd

Tx,

Sigi

Sigi

  • Newbie
  • *
  • Posts: 3
Re: Arch Linux and NixOS don't show any tty device in dmesg
« Reply #3 on: October 10, 2016, 07:54:17 PM »
I updated my pockethernet successfully.


Device data:
HW version 4
Current firmware 9 (now 21)

But no the new firmware also doesn't show the expected dmesg entry.
« Last Edit: October 11, 2016, 09:36:45 AM by Sigi »