Author Topic: dead unit?  (Read 130 times)


  • Newbie
  • *
  • Posts: 1
dead unit?
« on: March 09, 2018, 03:37:30 AM »
Hello I just got a new PE. I charged it up overnight did the firmware update and ran a few tests with it and all looked good. It sat in my bag for a week before I needed to use it, now it wont power up at all. Let it charge for a few hours ( led comes on ) when unplugged its lifeless, power button does not seem to do anything, no bluetooth either - anything I can do or is it dead?

Things I have tried -

Leaving on charge for 5 hours
Reflashing firmware
holding power button for 10 seconds then plugging into usb to reset
holding power button for 60 seconds

I put a charging monitor on the usb side and its only drawing 1.1w so it looks like its either full or does not want to charge - LED is white when plugged in
« Last Edit: March 09, 2018, 03:46:10 AM by ChasingTraction »


  • Newbie
  • *
  • Posts: 1
Re: dead unit?
« Reply #1 on: March 11, 2018, 08:15:52 PM »
I have the same problem. Mine worked for 5 months and now it wont stay on. Did you find a solution?


  • Newbie
  • *
  • Posts: 9
  • Powered by ethernet
    • Homepage
Re: dead unit?
« Reply #2 on: March 17, 2018, 02:51:53 AM »
I'd say "see if it powers up from USB" but afaik that's either not supported or not recommended.
Maybe the battery connector internally has come loose? It's not too difficult to open the enclosure and have a look.
I brake... For lanparties!
... Also: can't apply avatar settings on this forum.